Send Webpage - Issue with URLS for images

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Send Webpage - Issue with URLS for images

Postby algoabay » 1:07pm, Mon 13 Apr, 2015

This relates to an install that has just been upgraded v3.0.12.
I have never tried this before and I don't know if there are any limitations I should be aware of but my plan was to use Send Webpage to send a snapshot of a webpage to a group of people on a regular basis.
The webpage in question is very simple and contains 4 images (4 temperature graphs).
Unusually, the server hosting the webpage is on port 8100.

The webpage is sent as expected but while the text is displayed correctly the images do not render. The webpage originally used relative links to the images, I have tried changing these hyperlinks to full absolute links that explicitly include the port number but the images still do not render. I think but have not yet proven that the port numbers are not coming through.

Can anyone suggest how I can confirm what is being sent and how I can troubleshoot this further?

James
algoabay
phpList newbie
 
Posts: 2
Joined: 12:35pm, Mon 13 Apr, 2015

Re: Send Webpage - Issue with URLS for images

Postby Dragonrider » 2:07pm, Mon 13 Apr, 2015

I've just tested this on one of my phpList installations (I've never had the need to try it in anger).

Everything came through except the images. However, at the top of the resulting email was a pale yellow box asking if I wanted to see the images, clicking on this resulted in showing of the images in the HTML version, obviously the text only version came up with basic font and no images at all.

Have you checked that your email viewer allows images to be shown?
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Send Webpage - Issue with URLS for images

Postby algoabay » 2:47pm, Mon 13 Apr, 2015

Ah, many thanks for checking this out. It turns out that email programs are not very consistent in rendering of HTML that works fine in a browser. Even HTML that W3C validates is not good enough especially if the images are in PNG format.

As far as I can see phplist is working correctly and now that I have converted my images to jpgs, the pages render fine in Outlook on Windows7 and Gmail on Android.

Thanks for your assistance.
James
algoabay
phpList newbie
 
Posts: 2
Joined: 12:35pm, Mon 13 Apr, 2015


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 2 guests