[solved] Editor (in FF3) converts question mark to omega

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

[solved] Editor (in FF3) converts question mark to omega

Postby Guest » 5:07am, Thu 25 Sep, 2008

Here's the issue: when I'm composing an email (the "send a message" page), and I enter a "?", the editor (FCKEditor) converts it into "ω". It's that simple and that weird; just key in "?", hit the "Source" button, and the "?" is now "ω". If I send out the email, it gets sent with the omega and not the question mark.

This happens in Firefox, but not IE.

I'm using charset iso-8859-1, but I've tried switching to UTF-8, and it makes no difference. I've also tried entering the "?" directly in the source.

Has anyone seen anything like this before?
Guest
 

Postby H2B2 » 1:29pm, Thu 25 Sep, 2008

No, I haven't, but a quick look at the FCKeditor site and forums shows that the problem was reported by several FCKeditor users, e.g. http://dev.fckeditor.net/ticket/307

Try this search string in google, and hopefully you'll find an answer there: site:FCKEditor.net ω
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby Guest » 5:47am, Fri 26 Sep, 2008

Thanks for the hint. In the FCKEditor forums, they offer a simple solution, but the issue is a little more nuanced and took some digging to resolve.

The basic solution is to disable FCKConfig.ProcessHTMLEntities in fckconfig.js. This didn't work for me, however.

The real problem was that I had made some changes to fckeditorcode_gecko.js in an editor that did not support unicode encoding, and it converted special characters (like omega) into question marks. Thus a line like this:
Code: Select all
'Ω':'Omega'

became this:
Code: Select all
'?':'Omega'

So I had to go get an un-edited copy of fckeditorcode_gecko.js, open it in an editor that supported unicode encoding (I used Abiword), re-apply my changes, and save it as encoded (UTF-8) text. That preserved the special characters.

That, together with disabling FCKConfig.ProcessHTMLEntities, solved the problem of converting question marks to omega.
Guest
 

Postby H2B2 » 6:04am, Fri 26 Sep, 2008

Thanks for posting this solution in such detail! I'm sure this will be helpful to others.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 3 guests