[solved] Can't connect to gmail-pop.l.google.com,995:

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

[solved] Can't connect to gmail-pop.l.google.com,995:

Postby Guest » 3:12am, Sun 05 Oct, 2008

First of all I went through all the posts in this forum for "handling bounce processing through pop" but could get it working.

I am new to Phplist and got everything working except bounce processing through pop. We have our own linux server with centos 5 on it. I prefer using google app or gmail account for pop processing.

Error:-
Cannot create POP3 connection to pop.gmail.com: Can't connect to gmail-pop.l.google.com,995: Permission denied

$bounce_protocol = 'pop';
$bounce_mailbox_host = 'pop.gmail.com';
$bounce_mailbox_user = 'user@gmail.com';
$bounce_mailbox_password = 'password';

Tried various options like
$bounce_mailbox_port = "995/pop3/ssl";
$bounce_mailbox_port = "995/pop3/ssl/novalidate-cert";

tried options in http://forums.phplist.com/viewtopic.php ... ight=gmail still get the same error.
I can pop it through outlook express but not through phplist.

I have "php-imap-5.1.6-20.el5_2.1" installed on Centos 5 along with Apache 2.2.3 and postfix

If needed I can forward the bounce mails from gmail to any other free pop service which could work with Phplist. Provide me any free working pop account supported by Phplist. If we can compile a list of various working configurations, I believe this will help lot of new users like me.
Guest
 

Postby Guest » 8:17pm, Sun 05 Oct, 2008

Finally got it working with all pop servers including gmail.com, gmx.com and hosted services.

There was absolutely no problem with Phplist but with apache and SELinux Permission policy. It was not letting Phplist making network connection on outgoing ports due to security issues.

If you are facing bounce processing issue then follow these steps.
-> Check your "/var/log/messages" file.
-> If it says "SELinux is preventing the http daemon from connecting to network port XXX" (XXX = 995 or 110 or your pop port) then run following command
# setsebool -P httpd_can_network_connect=1

If you do not have access to your servers (Hosted environment) check with your service provider for outgoing network connections settings and to set the above variable.

http://fedoraproject.org/wiki/SELinux/apache
http://beginlinux.com/index.php/server_ ... nt=1&page=
Guest
 

100% Working - Bounce Processing POP Settings

Postby Guest » 8:35pm, Sun 05 Oct, 2008

gmail.com Bounce Processing Settings - 100% Working
===================================================

$bounce_protocol = 'pop';
$message_envelope = 'username@gmail.com';
$bounce_mailbox_host = 'pop.gmail.com';
$bounce_mailbox_user = 'username@gmail.com';
$bounce_mailbox_password = 'password';
$bounce_mailbox_port = "995/pop3/ssl/novalidate-cert";


GMX.com (Free 5 GB Pop/smtp service provider)- 100% Working
============================================
$bounce_protocol = 'pop';
$message_envelope = 'username@gmx.com';
$bounce_mailbox_host = 'pop.gmx.com';
$bounce_mailbox_user = 'username@gmx.com';
$bounce_mailbox_password = 'password';
$bounce_mailbox_port = "110/pop3/notls";
or
$bounce_mailbox_port = "110/pop3";

Both works

NOTE: Check with outlook express just to see if can connect to your mail service provider and download mails. Later use those parameters for above configuration. Once working through Phplist bounce processing discard outlook access to avoid double download. Else outlook might download and delete bounce emails from server and phplist bounce process might not get the bounce mails.
Guest
 

gmail bounce address working now!

Postby Guest » 4:41pm, Thu 20 Nov, 2008

Suggestions worked first time! Thanks for the time saver!!
Guest
 

Postby pmmenneg » 3:44am, Thu 12 Mar, 2009

I am using your gmail settings.

But when I go to the process bounces page, all I get is:

500 of 502 users processed
Identifying consecutive bounces
502 users processed

Which looks like it is just going over the database users with bounces, and checking how many they have. I am getting new bounces to the account on google, but it does not appear to be picking these up... if I change the setting in my config.php to comepletely wrong credentials, port numbers, etc, I still get this same message:

500 of 502 users processed
Identifying consecutive bounces
502 users processed

Any ideas?

Thanks,

Paul
pmmenneg
phpLister
 
Posts: 6
Joined: 10:48pm, Tue 10 Feb, 2009

Postby pmmenneg » 3:56am, Thu 12 Mar, 2009

Update, I am getting the following error when running processbounces from the command line:

Cannot create POP3 connection: Certificate failure: unable to get local issuer.

Which is weird because I am using:

novalidate-cert

Any ideas?

Paul
pmmenneg
phpLister
 
Posts: 6
Joined: 10:48pm, Tue 10 Feb, 2009

Got it working

Postby pmmenneg » 4:03am, Thu 12 Mar, 2009

Check thread 32256 in the forums.
pmmenneg
phpLister
 
Posts: 6
Joined: 10:48pm, Tue 10 Feb, 2009

Postby pmmenneg » 5:29am, Thu 12 Mar, 2009

Sorry, one last question... once the pop mail processed, the messages were not deleted from the gmail account... should they have been?

Thanks,

Paul
pmmenneg
phpLister
 
Posts: 6
Joined: 10:48pm, Tue 10 Feb, 2009

Delete Messages in Bounces...

Postby maquido » 7:01pm, Tue 17 Mar, 2009

at line

101, on config.php

Code: Select all
# set this to 0 if you want to keep your messages in the mailbox. this is potentially
# a problem, because bounces will be counted multiple times, so only do this if you are
# testing things.
$bounce_mailbox_purge = 1;


You have the answer
maquido
phpLister
 
Posts: 10
Joined: 4:21am, Tue 31 Aug, 2004

Postby pmmenneg » 8:49pm, Tue 17 Mar, 2009

I have it set to 1, but when I log into the gmail account that the bounces go to, the messages are all still there.

However, these remaining messages don't appear to get processed a second time by phplist, and are only counted once it looks like, so I don't think it's a big deal, but it is a bug I think.

paul
pmmenneg
phpLister
 
Posts: 6
Joined: 10:48pm, Tue 10 Feb, 2009

Re:

Postby kurtr » 5:06pm, Fri 20 Nov, 2009

pmmenneg wrote:I have it set to 1, but when I log into the gmail account that the bounces go to, the messages are all still there.


There is a setting in your actual gmail account that determines what happens to mail once it is pulled using POP. In Gmail: Settings -> Forwarding and POP -> When messages are accessed with POP...

Maybe change this setting to "archive" and then try it again.
kurtr
phpList newbie
 
Posts: 1
Joined: 4:45pm, Fri 20 Nov, 2009

Re: [solved] Can't connect to gmail-pop.l.google.com,995:

Postby Wooper2340 » 8:52am, Fri 19 Nov, 2010

I was able to solve this very error.

What I had failed to do was to enable POP on the Googlemail account.(basic schoolboy error).
Also I had set $bounce_mailbox_port = "995/pop3/ssl"; to enable ssl.

Hope this helps some of you.
Wooper2340
phpList newbie
 
Posts: 3
Joined: 9:27am, Wed 17 Nov, 2010

Re: [solved] Can't connect to gmail-pop.l.google.com,995:

Postby scanner001 » 9:04pm, Wed 13 Apr, 2011

Hi,

I'm having this issue also. I just setup phplist and the only part that is causing me any pain is bounces.

when i process i get
Can't connect to gmail-pop.l.google.com,995:

my config.php is set as below with the correct password and domain set. I have tried these settings on my cell phone and it connects without issue

Please help i'm hosting on hostgator

$bounce_protocol = 'pop';

# set this to 0, if you set up a cron to download bounces regularly by using the
# commandline option. If this is 0, users cannot run the page from the web
# frontend. Read README.commandline to find out how to set it up on the
# commandline
define ("MANUALLY_PROCESS_BOUNCES",1);

# when the protocol is pop, specify these three
$bounce_mailbox_host = 'pop.gmail.com';
$bounce_mailbox_port = "995/pop3/ssl/novalidate-cert";
$bounce_mailbox_user = 'embounce@domain.com';
$bounce_mailbox_password = 'password';

# the "port" is the remote port of the connection to retrieve the emails
# the default should be fine but if it doesn't work, you can try the second
# one. To do that, add a # before the first line and take off the one before the
# second line

# when the protocol is mbox specify this one
# it needs to be a local file in mbox format, accessible to your webserver user
$bounce_mailbox = '/var/spool/mail/listbounces';

# set this to 0 if you want to keep your messages in the mailbox. this is potentially
# a problem, because bounces will be counted multiple times, so only do this if you are
# testing things.
$bounce_mailbox_purge = 1;

# set this to 0 if you want to keep unprocessed messages in the mailbox. Unprocessed
# messages are messages that could not be matched with a user in the system
# messages are still downloaded into PHPlist, so it is safe to delete them from
# the mailbox and view them in PHPlist
$bounce_mailbox_purge_unprocessed = 1;

# how many bounces in a row need to have occurred for a user to be marked unconfirmed
$bounce_unsubscribe_threshold = 5;
scanner001
phpList newbie
 
Posts: 1
Joined: 8:58pm, Wed 13 Apr, 2011


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest