Two Emails Sent Out - Html and Text

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

Two Emails Sent Out - Html and Text

Postby AHorizons » 10:55pm, Fri 09 Jun, 2006

I'm not sure if this a bug or correct, but it sends out two emails for everything, both one thats html and one thats text. I thought it was supposed to imbed the text version into the html one.

If not, is there a way to turn off the text version for people who prefer html (including the confirm/welcome)

Thank you
AHorizons
phpLister
 
Posts: 7
Joined: 7:04pm, Fri 02 Jun, 2006

Postby Totto » 6:15pm, Sat 10 Jun, 2006

Both versions are sent only when sending test messages. That is to see how each version (text / html) will look like when received by a user. When sending messages to lists users will receive only the version they have chosen to - plain text or html.
It's not a bug, just a feature that helps the one who send messages to have an idea how messages will look like before actually sending them.
To all forum users: Search the forums when you got a question first! Your question may have already been asked many times before and also many times answered. The search feature is your best friend on any forums of this kind!
Totto
PL Master
 
Posts: 370
Joined: 11:20pm, Tue 31 Jan, 2006

Postby Hernol » 12:47pm, Tue 13 Jun, 2006

When sending no-test messages you can go to "format" and choose "Send as: HTML".
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

HTML vs Text verson

Postby JohnJ » 1:33pm, Tue 13 Jun, 2006

Is there a way to eliminate the text version? My text version is a mess from the html one. Or is there anyway to correct the text version?
JohnJ
phpList newbie
 
Posts: 3
Joined: 1:26pm, Tue 13 Jun, 2006

Postby JohnJ » 2:35pm, Tue 13 Jun, 2006

I sent a message (not a test one) to myself and another person. We are both set to receive html (box marked 1) messages.

I recieved mine, but it was in regular type and the other person never recieved theirs. Help :?:
JohnJ
phpList newbie
 
Posts: 3
Joined: 1:26pm, Tue 13 Jun, 2006

Postby Hernol » 2:40pm, Tue 13 Jun, 2006

In the subscribe page choose "Don't offer choice, default to HTML", so all the people will get the html messages.
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

Postby Hernol » 3:58pm, Tue 13 Jun, 2006

You will have to find a way by editing the message so it can be viewed in HTML and text, and they both look ok.
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

Postby JohnJ » 4:49pm, Tue 13 Jun, 2006

I did that. Everyone...including myself has marked the html for emails. I sent myself a message (not a test one) and got the text email. But, it is all messed up. Some of the words are alone on separate lines. Can this be fixed? Or deleted?
JohnJ
phpList newbie
 
Posts: 3
Joined: 1:26pm, Tue 13 Jun, 2006

Postby willifl » 10:22pm, Tue 13 Jun, 2006

in which of the mysql tables do I find the field for the "html" attribute? I imported quite a few user addresses and they all seem to be set to "0" and I'm looking for a way to fix it.

----
Never mind, I found it myself; it's htmlemail in phplist-user_user
willifl
phpList newbie
 
Posts: 1
Joined: 10:20pm, Tue 13 Jun, 2006

Postby H2B2 » 2:28am, Wed 14 Jun, 2006

You can mark all users to receive html mail through the admin interface too: admin interface -> Manage users -> reconcile users -> select "mark all users to receive html"
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby AHorizons » 12:00am, Thu 29 Jun, 2006

Totto,

This is happening with all messages, not just test ones. I've had to change it to default to html only as sending out two messages with each is spamming the recipients.
AHorizons
phpLister
 
Posts: 7
Joined: 7:04pm, Fri 02 Jun, 2006

Postby Totto » 5:55pm, Sun 02 Jul, 2006

AHorizons wrote:This is happening with all messages, not just test ones. I've had to change it to default to html only as sending out two messages with each is spamming the recipients.

It's not the way the system normally works and it's sending a pair of messages on test messages only, so sth should have got messed. But got no idea what, sorry.
To all forum users: Search the forums when you got a question first! Your question may have already been asked many times before and also many times answered. The search feature is your best friend on any forums of this kind!
Totto
PL Master
 
Posts: 370
Joined: 11:20pm, Tue 31 Jan, 2006

Postby Keith t » 2:04pm, Thu 06 Jul, 2006

When I send a text email and use an apostrophe it reads as an unrelated symbol. Here's an example:-

Keith's reads as Keith&s

Is there anything I can do to amend this glitch on text format messages? The HTML version works fine. Thank you.
Keith t
phpList newbie
 
Posts: 1
Joined: 1:08pm, Thu 06 Jul, 2006

Sending both HTML and Text on all email (not just test)

Postby drachomium » 2:58am, Fri 07 Jul, 2006

I was having the same problem as the AHorizons!

Before I changed something in the config files, this is the result for my messages with the setting (HTML and Text):

example 1
Code: Select all
total  text  html  both  PDF  both
570    18    0     554   0    0



example 2
Code: Select all
total  text  html  both  PDF  both
571    18    0     555   0    0


So i was a little irritated that my clients were getting double emails, in which i classify as spam! Two emails of the same message in two formats? Completely unprofessional, ridiculous.

1) I changed the setting in config (don't remember exactly name) to add a separate area while sending messages in text format. (However, I did this only after I realized that my text email were jumbled and completely parsed incorrectly.)

2) I began sending my emails in HTML format from the format tab(correct tab?) while sending a message to my mailing list.

These are my new result in which I'm satisfied and I hope this fixed my problem:

results A
Code: Select all
total  text  html  both  PDF  both
576    19    560   1     0    0


results B
Code: Select all
total  text  html  both  PDF  both
578    22    564   0     0    0


SO much more realistic that none should receive both other than me, as you can see in results A when i sent a test.

I hope this helps someone.
drachomium
phpLister
 
Posts: 10
Joined: 10:27pm, Tue 22 Mar, 2005

both txt and html formatted emails sent to whole list

Postby wolfmagic » 2:04am, Sat 07 Apr, 2007

both txt and html formatted emails sent to whole list after reconciling with “mark all users to receive html”.

listen up folks. this is happening across the board to all emails on all accounts in version 2.10.4. it is perhaps only supposed to do it on the test, but the point not yet made clear is that this is many times reliably reproducible and nothing is intuitive regarding the test.

now we're all a little irritated that our clients are ALL getting double emails which is classifiable as spam! [to paraphrase previous and now to quote direct]

"Two emails of the same message in two formats? Completely unprofessional, ridiculous."

total text html both PDF both
555 3 0 552 0 0

so basically, no matter what the user chooses when sending the message, that choice is overriddin by settings a good percentage of intuitive power users eager to start their email campaign would ever find to change before believing all the relevant settings were set.

and i don't want and will not go find/edit the config file at all to achieve something so basic - i'd rather log a documentation/enhancement if i can resolve it.

main page > admin interface > Manage users > reconcile users > select "mark all users to receive html" is nice advise that does not change this.

the problem stated which is everybody is getting two emails both html and text after reconciling users.

problem is that in "reconcile users" a key link is missing namely:

1. mark all users to receive html ONLY
AND/OR
2. mark all users to NOT receive txt

another soul says: In the subscribe page choose "Don't offer choice, default to HTML", so all the people will get the html messages.

now this is the answer i'm looking for and hopefully most others who perhaps did not need to edit their config file and make it prone to future errors. i will try that and see if it works. if it does i still have to log an enhancement request because:

when an intuitive user tests their message and knows it is to arrive in 2 formats and assumes this is not going to happen when they select html only in the interface to send the message, then it comes as a shocking surprise to them that they in fact may have sent text-only messages which is exactly what happened to us on our first real run post-successful tests.

we had to find out the painful way that "user format settings" override the listadmin settings on the launch pad and that the listadmin must first somehow intuit to go to main page > admin interface > Manage users > reconcile users > select "mark all users to receive html".

so we did that and then found that all customers were getting both. great! on to the next non-intuitive hurdle. see the need? fill it.

a simple few words near the test button that says "more info" and links to guidline that spells out 3 extra steps to do before launching an email into the real world seems obvious to some given phplist is stamped on both pieces of mail and is obviously not earning points by performing this way.

wolf out!
wolfmagic
phpList newbie
 
Posts: 3
Joined: 4:06am, Fri 06 Apr, 2007

Next

Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest