I get no bounces [solved]

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

I get no bounces [solved]

Postby pastra » 11:41am, Tue 19 Dec, 2006

I get no bounces even though I know I should. My server has Safe Mode turned off and the IMAP extension.
Here´s my configuration:

# $message_envelope = 'noreply@mydomain';


$bounce_mailbox_host = 'localhost';
$bounce_mailbox_user = 'noreply@mydomain';
$bounce_mailbox_password = 'password';

I have altered between theese two settings:
#$bounce_mailbox_port = "110/pop3/notls";
$bounce_mailbox_port = "110/pop3";

but still no bounce

PLEASE HELP!
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Postby Hernol » 1:16pm, Tue 19 Dec, 2006

Do you have IMAP module enabled in your server?
You can check http://docs.phplist.com/PhpListConfigBounces for help
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

Postby pastra » 2:15pm, Tue 19 Dec, 2006

Yes. I have read that documentation. Can´t find the answer there.
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Re: I get no bounces

Postby H2B2 » 9:37pm, Tue 19 Dec, 2006

"localhost" may not be the correct value in your case. Try using the full address of your pop server instead, for instance: $bounce_mailbox_host = 'pop.yourdomain.com';

You could also double check you entered the correct username (e.g. "username@yourdomain.com", or sometimes just "username") and password.

Do you have a particular reason for not enabling the message envelope setting?
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby pastra » 8:48am, Wed 20 Dec, 2006

Sorry but I have already tried different values such as localhost or username@mydomain.com
The username and the password are OK. I get an errormessage from the script when it isn´t. Any other suggestions?
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Postby Hernol » 1:10pm, Wed 20 Dec, 2006

What's the error you got?
Hernol
Admin
 
Posts: 1378
Joined: 6:39pm, Thu 18 May, 2006
Location: Argentina

Postby pastra » 1:47pm, Wed 20 Dec, 2006

Sorry, my fault -bad english. I get no errormessages when I have the correct settings for email etc. It´s only when I try with wrong settings(to see if it works) that I get errormessages. That´s the problem. Everything seems fine, no errormessages. But...I get no bounces!
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Postby Tiger bob » 8:24am, Sat 23 Dec, 2006

Tiger bob
Moderator
 
Posts: 103
Joined: 7:12am, Sun 15 May, 2005

Postby pastra » 12:58pm, Wed 03 Jan, 2007

I´ve read that to. Now I have updated to the latest version which also means that the file processbounces.php isn´t overriding the settings in the config.php any longer. The upgrade didn´t help me,thou . I´m still getting no bounces. Give me a clue, someone.PLEASE!
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Postby pastra » 4:00pm, Wed 03 Jan, 2007

FINALLY!! I´ve solved it! My server was overriding my settings in the config.file
For security reasons the server changed the return-path of the letter. Now everything is working just fine. Thanks all for your efforts. :D :D
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden

Postby alrosen » 11:44pm, Sun 18 Mar, 2007

pastra, you say that your server was overriding your return-path in your message. how do you set the return-path? lists/admin/config/config.php only has configuration for the message_envelope, not for return-path.
Also, can you give a little more details on how you avoided the server override of the return-path?

thanks
alrosen
phpList newbie
 
Posts: 1
Joined: 11:37pm, Sun 18 Mar, 2007

Postby pastra » 5:02pm, Mon 19 Mar, 2007

Hi
I´m on a hosted server. This is the part that my hosted server was overriding:

$message_envelope = "noreply@mydomain.com";

# when the protocol is pop, specify these three
$bounce_mailbox_host = 'localhost';
$bounce_mailbox_user = 'noreply@mydomain.com';
$bounce_mailbox_password = 'password';

The server changed the error to adress to a default adress for my domain. It was easy to see(when I finally did) from the source of the letters sent out from my list.
This is how the source in a letter from my phplist looked like before talking to my ISP.

Return-path: default@mydomain.com
Envelope-to: someadress@domain.com
Delivery-date: xxx
Received: xxx
To: someadress@domain.com
Subject: Something
Date: xxx
From: my from adress
Message-ID: xxx
X-Priority: 3
X-Mailer: PHPMailer [version 1.73]
X-Mailer: phplist v2.10.4
X-MessageID: a number
X-ListMember: someadress@domain.com
Precedence: bulk
MIME-Version: 1.0


This is what changed after talking to my ISP about the problem.Changes in red

Return-path: noreply@mydomain.com
Envelope-to: someadress@domain.com
Delivery-date: xxx
Received: xxx
To: someadress@domain.com
Subject: Something
Date: xxx
From: my from adress
Message-ID: xxx
X-Priority: 3
X-Mailer: PHPMailer [version 1.73]
X-Mailer: phplist v2.10.4
X-MessageID: a number
X-ListMember: someadress@domain.com
Precedence: bulk
Errors-To: noreply@mydomain.com
MIME-Version: 1.0

Hopefully this will make some sense for you!
pastra
phpLister
 
Posts: 13
Joined: 8:20pm, Wed 22 Nov, 2006
Location: Stockholm, Sweden


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest