Page 1 of 1

[how to] Change textline input size of the subscribe form

PostPosted: 1:27am, Fri 02 Mar, 2007
by Andrei
This is driving me bonkers!

I've set up a subscriber page here:
http://tallentedchef.com/newsletter/?p=subscribe&id=1

I've managed to configure most aspects of how this form looks but I can't for the life of me figure out how to change the form text input size. The default is 40, but it is obviously too big for the page.

I've tried editing this snippet in defaultconfig.inc :

# width of a textline field
"textline_width" => array ("40",
"width of a textline field (numerical)","text"),

Editing this number does not seem to affect the form at all.

Hope you can help!

PostPosted: 5:16am, Fri 02 Mar, 2007
by H2B2
Yes that's strange.
The textline_width variable should be defined in defaultconfig.inc. If defined, that value should be used by subscribelib2.php to generate the input fields width for the subscribe form. If not defined it defaults to 40, as you can see in the code, about line 679 of subscribelib2.php:
Code: Select all
 $textlinewidth = sprintf('%d',getConfig("textline_width"));
  if (!$textlinewidth) $textlinewidth = 40;
  list($textarearows,$textareacols) = explode(",",getConfig("textarea_dimensions"));

You could try changing $textlinewidth = 40 and see if that works. Not a very elegant solution I admit.

PostPosted: 5:28am, Fri 02 Mar, 2007
by H2B2
Ah, I just checked as I thought there should be a simple solution: On the configuration page of the admin backend you'll find this setting:
edit width of a textline field (numerical)
40

PostPosted: 2:54pm, Fri 02 Mar, 2007
by Andrei
Holy Cow, you are right!

I can't believe I missed that staring me right in the face! I've edited just about everything else in the config backend but somehow I just didn't see it until you pointed it out. DOH!

Thanks for your help!!!!

PostPosted: 5:10pm, Fri 02 Mar, 2007
by Andrei
So, editing the number in the config takes care of the input fields on the subscribe page, but on the unsubscribe page the field is still the default 40.

I have edited defaultconfig.inc, subscribelib2.php and in the admin area of phplist. All are set to 30 in stead of the default 40.

Any ideas about where to go next?

PostPosted: 9:05pm, Fri 02 Mar, 2007
by Andrei
Similar problem:

On the page where a subscriber is cancelling and asked for the reason for cancelling, the submit button has nothing in the "value" field. Hence, a submit button with no text. Any idea how to fix this?

Should I be posting this in a different area of the forum? I'm not so sure this qualifies as "Tips" any more.

PostPosted: 9:35pm, Fri 02 Mar, 2007
by Andrei
LOL hey maybe I can figure all this out myself before an admin takes a look
:P

ok, the submit button text was fixed by adding the following line to /texts/english.inc

$strUnsubscribe ='Unsubscribe';

Perhaps this line could be included in the next update?

Still can't figure out how to change the unsubscribe textfield size, but considering the solution above I suspect there is a line or snippet missing somewhere...

Another treasure hunt :roll:

PostPosted: 10:59pm, Sun 04 Mar, 2007
by Andrei
Finally found it in the root of phplist install folder in index.php