[solved] Email Fails to send

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

[solved] Email Fails to send

Postby Grudgeuk » 9:32am, Tue 06 Mar, 2007

First of all, hello to all! :D

I have been playing around with Phplist now for a few days and I have got to say I am really impressed with the power of it and it ease of setup. I got my local install working well. Now I have the remote setup working well too, apart from it fails to send an email, when I send a test email to a valid email address. Also when you sign up for a newsletter it should send an email this also fails.

I have been able to find all the information so far when I have come across problems using the Forum but this has got me stumped as I cannot find anyone else who has had this issue.

BTW I know the host can send emails as I have a forum and that sends emails fine.

Any pointers would be appreciated.

Thanks
Grudgeuk
phpList newbie
 
Posts: 2
Joined: 8:21am, Tue 06 Mar, 2007

Postby H2B2 » 10:29pm, Tue 06 Mar, 2007

I suppose you already checked that test mode is disabled in config.php. So you'd best review your connection settings or try enabling smtp in config.php.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby shea » 11:16pm, Tue 06 Mar, 2007

I'm having the same problem right now. How do I enable the SMTP?

And does the install come with PHPMailer or does that need a separate install?
shea
phpLister
 
Posts: 5
Joined: 11:11pm, Tue 06 Mar, 2007

Postby H2B2 » 11:29pm, Tue 06 Mar, 2007

You can enable SMTP in the config.php file. phpmailer can be enabled or disabled in config.php too.
Code: Select all
# If you want to use the PHPMailer class from phpmailer.sourceforge.net, set the following
# to 1. If you tend to send out html emails, it is recommended to do so.
define("PHPMAILER",1);

# To use a SMTP please give your server hostname here, leave it blank to use the standard
# PHP mail() command.
define("PHPMAILERHOST",'');

# if you want to use smtp authentication when sending the email uncomment the following
# two lines and set the username and password to be the correct ones
#$phpmailer_smtpuser = 'smtpuser';
#$phpmailer_smtppassword = 'smtppassword';
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby shea » 12:47am, Wed 07 Mar, 2007

Thanks, I've given it a shot.

It looks like I have all my settings right. (TEST,0), PHPMAILER and all. Even checked to make sure my default port is 25, so no need for that extra line of code to compensate for that.

Do you have any other ideas why it might not be working?
shea
phpLister
 
Posts: 5
Joined: 11:11pm, Tue 06 Mar, 2007

Postby H2B2 » 1:43am, Wed 07 Mar, 2007

It differs a bit, as each provider may have a specific setup for using SMTP. For instance, any of these settings might apply:
Code: Select all
define("PHPMAILERHOST",'mail.yourdomain.com');
define("PHPMAILERHOST",'smtp.yourdomain.com');
define("PHPMAILERHOST",'whatever.yourdomain.com');
define("PHPMAILERHOST",'mail');
define("PHPMAILERHOST",'localhost');
define("PHPMAILERHOST",'your.ip.number');
etc.

As for the username, these might apply for instance:
Code: Select all
$phpmailer_smtpuser = 'smtp_username';
$phpmailer_smtpuser = 'smtp_username@yourdomain.com';

You'll have to check with your host, or find out by trial-and-error.


In case you have a non-standard smtp port, you might try adding this line in config.php:
Code: Select all
$phpmailer_smtpport = '587';
EDIT- Note: for this to work you'll need to apply a minor code modification, as explained in the FAQs.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby shea » 7:54pm, Wed 07 Mar, 2007

Thanks for the help again, but it still doesn't appear to be sending email.

TEST is set to 0.

PHPMAILERHOST has been set to localhost.

There is no authentication.

$phpmailer_smtpport = '25'; <- even though this is default, I thought I'd give it a shot.

And still nothing working. Any other ideas?
shea
phpLister
 
Posts: 5
Joined: 11:11pm, Tue 06 Mar, 2007

Postby Grudgeuk » 7:55pm, Wed 07 Mar, 2007

H2B2 wrote:I suppose you already checked that test mode is disabled in config.php. So you'd best review your connection settings or try enabling smtp in config.php.


I had not checked that, I now have and it was set, so changed to 0 and it is now working great. Thanks. Weird how it worked locally mind you.

:D
Grudgeuk
phpList newbie
 
Posts: 2
Joined: 8:21am, Tue 06 Mar, 2007

Postby H2B2 » 2:52am, Thu 08 Mar, 2007

shea wrote:PHPMAILERHOST has been set to localhost.

"localhost" might be incorrect, as I tried to say in my previous post. Check with your provider if you aren't sure what is correct in your particular case.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby jezzer » 10:48am, Thu 08 Mar, 2007

for some reason , im suffering from a similar problem ,

ive changed test to 0 , its saying that the queue has been processed but nothing is being delivered.

when i send the email out it sends to my email account , but none of the other 62 users.

The list is set to active ..

any ideas ?
jezzer
phpList newbie
 
Posts: 1
Joined: 10:42am, Thu 08 Mar, 2007

Postby H2B2 » 3:25pm, Thu 08 Mar, 2007

I recall having seen one or two posts describing a similar issue, i.e. that messages were only delivered to email addresses within the sender's domain and not outside the sender's domain. If I remember correctly this issue was related to the server configuration and was fixed by the provider.

You might try to confirm this is the same issue, by subscribing some additional email addresses with your own domain name and run some tests.
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest