[plugin: Mail2List] Send mail to your list via email client

3rd party code for phpList

Postby SaWey » 9:45am, Wed 02 May, 2007

Are you sure you are subscribed to that list? :D

Normally it should go out, maybe there's some problem with a spam filter holding your email?

try sending a plain text mail to the list and process that one.

Did you use HTML in the footer?
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

Postby blair.sawler » 11:43am, Wed 02 May, 2007

Ha ha! Yes I am subscribed (with two seperate E-mail accounts, and providers). There is HTML in the footer, and when I send the E-mail through PHP it gets delivered, but via E-mail it does not seem to be.
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

Postby SaWey » 11:49am, Wed 02 May, 2007

Sometimes HTML code is blocked by spam-filters.

Can you post the code of your footer please.
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

Postby blair.sawler » 12:30pm, Wed 02 May, 2007

Sure. I am not sure where it is stored in PHP List, so I just posted it from a message I sent through the system:

<DIV>--<BR>This message was sent from Scouts Rivorton to
blair.sawler@rogers.com. It was sent from scoutsrivorton.org.<BR><BR>To update
your preferences and to unsubscribe visit <A>this
link</A>.<BR><BR>To forward this message to a friend of Scouting, please click
<A>this
link</A>.<BR><BR>Thank you<BR><BR>Scouts Rivorton
Area<BR>www.scoutsrivorton.org<BR>Check out our site and join the Friendly Fire
Forum!</DIV><BR>
<STYLE><poweredphplist></STYLE>
<SPAN>powered by <A>php list</A></SPAN> </BODY></HTML>
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

Postby blair.sawler » 1:10pm, Wed 02 May, 2007

FYI I sent a plain text E-mail and it was not delivered either....
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

Postby blair.sawler » 1:43pm, Wed 02 May, 2007

Just to keep you up to date.... I deleted the test list I was using, and the mail2list settings for it.

I then created a new list and a new mail2list setting for it.

No luck.
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

Postby blair.sawler » 11:00pm, Wed 02 May, 2007

Hey SaWey

What do you think could be the problem? I can't see it being HTML given that I can receive the E-mails through the conventional list.

I am at a loss here. The only thing I changed in the footer was the addition of [EMAIL] as a tag, and reworking of the text....

I have tried changing to a new list with a new E-mail address for it, and sent it to a new E-mail address, but the E-mails are not being sent out even though everything says it should be, and BTW there are no SPAM filters set up on the E-mails, I turned it off at the server level.

I could use some guidance. Thanks.
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

Postby SaWey » 11:30pm, Wed 02 May, 2007

could you maybe pm me login details of your phplist,
then I could take a look and try to reproduce it on my server.

I still do not have a clue and am not able to reproduce it.
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

Postby blair.sawler » 11:37pm, Wed 02 May, 2007

Sent the info. Thanks!
blair.sawler
PL Nut
 
Posts: 21
Joined: 3:05pm, Sun 26 Nov, 2006

default plugin

Postby elton.sbruzzi » 6:50pm, Tue 15 May, 2007

Hello,

How can I enable the default plugin?
Where is the WebGUI?
How I send email to one specified list?

I saved the the files in the plugin directory, but I couldn´t continue instaled that.

thanks

Elton
elton.sbruzzi
phpList newbie
 
Posts: 1
Joined: 6:32pm, Tue 15 May, 2007

Postby SaWey » 8:12pm, Tue 15 May, 2007

It seems like you haven't used phplist before.

The docs explain a lot, but to answer your questions:

-How to enable the plugins-

in your config.php, look for
Code: Select all
# you can create your own pages to slot into PHPlist and do certain things
# that are more specific to your situation (plugins)
# if you do this, you can specify the directory where your plugins are. It is
# useful to keep this outside the PHPlist system, so they are retained after
# upgrading
# there are some example plugins in the "plugins" directory inside the
# admin directory
# this directory needs to be absolute, or relative to the admin directory

define("PLUGIN_ROOTDIR","/home/me/phplistplugins");

# uncomment this one to see the examples in the system (and then comment the
# one above)
#define("PLUGIN_ROOTDIR","plugins");

And change to your needs.

-The webGUI-
The webgui is the admin-side of phplist.

-how to send an email to a list-
configurable in the webGUI (admin-side) of phpList

If that's not enough, please read http://docs.phplist.com/MailToList
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

Postby PC » 11:44pm, Fri 25 May, 2007

I'm having a problem whereby when I goto "process new mails" it opens the new page and stops halfway through after it prints up Processing list 'list 3'. I think it's getting stuck trying to access the emails from the server so I might have a problem with the mail in that respect.

I've tried using a different pop account i have on a different server and it did the same, I tried using a gmail account with the following details:

Email: <myusername>@gmail.com
Host: pop.googlemail.com
Port: /pop3:995/ssl
Login: <myusername>@gmail.com
Password <mypassword>

This wouldn't work either. Any ideas? Anyone have a test email they know to work that I might try out? Or any suggestions of what else I might look for?
PC
phpList newbie
 
Posts: 2
Joined: 12:31pm, Fri 25 May, 2007

Postby SaWey » 8:59am, Sat 26 May, 2007

Hey,

You should get a message indicating if the script is connected to the pop-account or not.

Does it not show the footer of the regular admin-page?

Have you modified any of the code?
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

Postby PC » 11:55am, Sat 26 May, 2007

Hi Savey,

I haven't changed any of the code and the mysql seems to be setup fine for everything. I've uploaded a picture:

redml. info images image gif

You'll have to insert the dots and slashes!
(Can't post a link on this forum... that really is a daft thing to do when people are going to be talking about their websites!!!)

Take a look and see what you think. I'll also pm you the details to look behind the scenes if you like, this is a test server anyway so I'm not too bothered about people having the backend details.

Thanks

Paul
PC
phpList newbie
 
Posts: 2
Joined: 12:31pm, Fri 25 May, 2007

Postby SaWey » 1:51pm, Sat 26 May, 2007

Hey PC

I have located the problem,
there seems to be a problem with the 'imap_open' function of PHP, please ask your hosting company if they can give you more info about that.
SaWey
PL Master
 
Posts: 192
Joined: 8:28pm, Wed 08 Mar, 2006
Location: Belgium

PreviousNext

Return to Contributions: Plug-ins, Add-ons, Mods

Who is online

Users browsing this forum: Google [Bot] and 1 guest