Upgrade to 3.0.10 now export does not work

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Upgrade to 3.0.10 now export does not work

Postby susans » 5:38pm, Thu 23 Oct, 2014

I just upgraded to 3.0.10 and when I export subscribers, it tells me it's working on it, the bar fills in and All Done. Then this shows up on the screen -
id,Email,Is this subscriber confirmed,Is this subscriber blacklisted,Did this subscriber - an nothing else happens.
In the previous versions, I would get a download to approve and then the file would be saved to the directory I chose. Now nothing happens. Tried it in Firefox and Chrome and I get the same result. I cleared my cache and history and tried it again. Nothing.
susans
phpList newbie
 
Posts: 2
Joined: 4:29pm, Sat 04 Oct, 2014

Re: Upgrade to 3.0.10 now export does not work

Postby Dragonrider » 9:52am, Fri 24 Oct, 2014

This has been reported on Mantis and is being looked into, apparently not everyone finds this error.

But yes, I do find it too!
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Upgrade to 3.0.10 now export does not work

Postby christallo » 9:22am, Sat 25 Oct, 2014

Got the same problem. I only get a message hwat says "all done" and than lists the first 2 lines of the export....(vers. 3.0.10 - also didn't work on 3.0.9)
Bildschirmfoto 2014-10-25 um 11.11.37.jpg
Bildschirmfoto 2014-10-25 um 11.11.37.jpg (143.26 KiB) Viewed 7079 times
christallo
phpLister
 
Posts: 5
Joined: 9:40am, Thu 04 Oct, 2007

Re: Upgrade to 3.0.10 now export does not work

Postby Ludwichdl » 8:17am, Sun 26 Oct, 2014

christallo wrote:Got the same problem. I only get a message hwat says "all done" and than lists the first 2 lines of the export....(vers. 3.0.10 - also didn't work on 3.0.9)
Bildschirmfoto 2014-10-25 um 11.11.37.jpg


I found the same problem on after upgrade to 3.0.10 today ( from 2.0.7 )
export subscribers

Processing export, this may take a while. Please wait
All done
id Email Is this subscriber confirmed Is this subscriber blacklisted Did this subscriber

Ludo de Lathouder
Ludwichdl
phpLister
 
Posts: 5
Joined: 10:58am, Thu 09 May, 2013

Re: Upgrade to 3.0.10 now export does not work

Postby Ludwichdl » 10:19am, Sun 26 Oct, 2014

The following did not solve the problem against expectations... nevertheless it may have something to do with it. See also the last line (version 3.0.7 and up)

Migrating from mysql.inc to mysqli.inc

From version 5.5 of PHP, the mysql_ functions have been deprecated. http://php.net/manual/en/migration55.deprecated.php
In future versions these functions will be removed and older versions of phpList will stop working.

To avoid this from happening, you will need to change your config file and find the line:
$database_module = "mysql.inc";
and change it to
$database_module = "mysqli.inc";

The change is very small, so if you do not see it, it is a lower-case letter i before the full stop.
If you do not have this line in your config file, then you do not need to do anything, and you can upgrade to the latest version of phpList.
This change applies to phpList version 3.0.7 and up. If you run a version prior to 3.0.7 you will need to upgrade to the latest version of phpList first.
Ludo de Lathouder
Ludwichdl
phpLister
 
Posts: 5
Joined: 10:58am, Thu 09 May, 2013

Re: Upgrade to 3.0.10 now export does not work

Postby Ludwichdl » 12:43pm, Sun 26 Oct, 2014

Dragonrider wrote:This has been reported on Mantis and is being looked into, apparently not everyone finds this error.

But yes, I do find it too!


I find these error logs entries in my site admin for this problem. The errors appear straight after trying to export subscribers. MySQL and PHP versions are up-to-date apparently. I deleted the PHPList and did a fresh install. No subscribers except admin after re-install.

[Sun Oct 26 07:22:36 2014] [error] [client xx.xxx.69.172] File does not exist: /home/roloncom/public_html/delathouder/site
[Sun Oct 26 07:20:51 2014] [error] [client yyy.yyy.111.71] File does not exist: /home/roloncom/public_html/404.shtml
[Sun Oct 26 07:20:51 2014] [error] [client yyy.yyy.111.71] File does not exist: /home/roloncom/public_html/robots.txt
[Sun Oct 26 07:17:25 2014] [error] [client xx.xxx.69.172 File does not exist: /home/roloncom/public_html/delathouder/site
Ludwichdl
phpLister
 
Posts: 5
Joined: 10:58am, Thu 09 May, 2013

Re: Upgrade to 3.0.10 now export does not work

Postby Ludwichdl » 11:33pm, Mon 27 Oct, 2014

The problem looks to be caused by incompatibility of MySQL/PHP.
The suggested solution did not work (use php version 5.4)

Here is the answer from Site5-
I've checked this further, and found that both domains referenced in your inquiry are running php ver 5.3.28, as shown below:

http://www.rolon.com.au/phpinfo.php
http://delathouder.net/phpinfo.php

Notwithstanding, while we haven't yet upgraded to mySQL 5.5, you could try changing your php version by following our guide here:
http://kb.site5.com/php/how-to-change-your-php-version/

You would simply add the following to your .htaccess file:
AddHandler application/x-httpd-php54 .php

That being said, if still encounter errors, please let us know the exact error (if possible, perhaps use awesomescreenshot plugin to capture the error, and attach it to your reply), and we can certainly investigate this further on your behalf.
Ludwichdl
phpLister
 
Posts: 5
Joined: 10:58am, Thu 09 May, 2013

Re: Upgrade to 3.0.10 now export does not work

Postby Ludwichdl » 10:57am, Wed 29 Oct, 2014

It looks like a compatibility issue. php ver 5.3.28 MySql 5.1. I solved the problem by restoring the old version 2.0.6 and using the old database connected to it. Ludo
Ludwichdl
phpLister
 
Posts: 5
Joined: 10:58am, Thu 09 May, 2013

Re: Upgrade to 3.0.10 now export does not work

Postby dhohmeyer » 11:45am, Thu 30 Oct, 2014

Leaving all external variables the same (DB version, PHP version, configuration settings), reverting to version 3.0.8 allows me to perform the export.

PHP Version 5.4.19
MySQL Server versions tested: 5.0.96-log, 5.5.37-35.0-log
dhohmeyer
phpList newbie
 
Posts: 2
Joined: 11:33am, Thu 30 Oct, 2014

Re: Upgrade to 3.0.10 now export does not work

Postby Dragonrider » 2:30pm, Fri 14 Nov, 2014

My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Upgrade to 3.0.10 now export does not work

Postby dhohmeyer » 3:42pm, Sat 15 Nov, 2014

Dragonrider wrote:Solution is available here.


Perfect! The solution fixed the export problem, thank you!
dhohmeyer
phpList newbie
 
Posts: 2
Joined: 11:33am, Thu 30 Oct, 2014


Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 1 guest

cron