Blank page on Install

Questions & Problems about Installing or Upgrading with Version 3 phpList.
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Re: Blank page on Install

Postby ScoobyDont » 6:46pm, Mon 08 Dec, 2014

Well, I solved it, at least for my issue.
I wasn't using (hadn't installed) phpMyAdmin, but on the off chance that perhaps there was something in that package or its dependencies that was required to make this thing work, I installed it...and phpList immediately started working. No idea which package did it. Don't really care at this point and I have wasted too much time on this to figure it out. I sure wish it was listed as a dependency up front (rather than "you can use phpMyAdmin"), as it would have saved me hours of futzing around trying to figure out what was missing when everything else seemed to work.

Here is the output of my phpMyAdmin install with dependencies.

Installing : php-mbstring-5.3.3-40.el6_6.x86_64
Installing : php-php-gettext-1.0.11-3.el6.noarch
Installing : libmcrypt-2.5.8-9.el6.x86_64
Installing : php-mcrypt-5.3.3-3.el6.x86_64
Installing : libxslt-1.1.26-2.el6_3.1.x86_64
Installing : php-xml-5.3.3-40.el6_6.x86_64
Installing : libtidy-0.99.0-19.20070615.1.el6.x86_64
Installing : php-tidy-5.3.3-40.el6_6.x86_64
Installing : php-bcmath-5.3.3-40.el6_6.x86_64
Installing : php-tcpdf-6.0.098-1.el6.noarch
Installing : fontpackages-filesystem-1.41-1.1.el6.noarch
Installing : dejavu-fonts-common-2.30-2.el6.noarch
Installing : dejavu-sans-fonts-2.30-2.el6.noarch
Installing : php-tcpdf-dejavu-sans-fonts-6.0.098-1.el6.noarch
Installing : phpMyAdmin-4.0.10.6-1.el6.noarch

edited to add: I didn't even have to run phpMyAdmin or configure anything beyond what I had already manually configured. Just the act of installing phpMyAdmin immediately made phpList work.

Also of note... I saw some instructions in some of the comments to disable SELinux.
I have SELinux enabled and it works fine.
ScoobyDont
phpLister
 
Posts: 12
Joined: 9:37pm, Sat 22 Nov, 2014

Re: Blank page on Install

Postby neerajmalve » 10:34am, Fri 12 Dec, 2014

Guys its php-mbstring pkg!
neerajmalve
phpList newbie
 
Posts: 1
Joined: 10:31am, Fri 12 Dec, 2014

Re: Blank page on Install

Postby hwang » 2:18pm, Wed 25 Feb, 2015

I have the same problem. With exactly the same database and config.php, v3.0.6 works perfectly, but any higher version does not not work, lists/admin/ returns a blank page with only PhpList header section.

I tried to create a new database, but it did not help at all. The blank page was always shown and it would not create tables in the database.

Like other users with this problem, I'm using a CentOS 6.5 virtual machine. I really hope someone would have a look at what really changed from v3.0.6 to v3.0.7.

I granted 777 to /tmp, it did nothing; I also installed php-mbstring, it did not help either :( :( :(
hwang
phpList newbie
 
Posts: 2
Joined: 8:44pm, Tue 24 Feb, 2015

Re: Blank page on Install

Postby danwaterloo » 1:36pm, Thu 26 Feb, 2015

Just to make sure, you restarted apache or rebooted the computer after you installed php-mbstring, correct?

I just went through the same update process the other day on one of my installs, and after rebooting (apache), everything worked well.

If it doesn't work ok, you might try loading php-myadmin, maybe it's one of the other dependencies that will make it work.
danwaterloo
PL Master
 
Posts: 276
Joined: 3:51am, Wed 30 Oct, 2013
Location: http://www.phplistsupport.com

Re: Blank page on Install

Postby hwang » 4:28pm, Sun 01 Mar, 2015

Oh yes, I forgot to restart Apache. After I restarted the Apache, the problem was solved:)
Yes, it is the php-mbstring package that solved the problem :D Thanks a lot
hwang
phpList newbie
 
Posts: 2
Joined: 8:44pm, Tue 24 Feb, 2015

Re: Blank page on Install

Postby jeeten29 » 5:07pm, Mon 09 Mar, 2015

Hello all,
I have same issue. I tried many times fresh copy on CentOS 6.0. I installed phplist 3.0.12 using cPanel. I have also installed latest apache, php, mysql.

After installation, It shows blank page. Root directory is /phplist and It is also set perfectly in config.php. website/phplist works fine and I am also able to add subscriber. only issue is with website/phplist/admin.

If anyone have solved this then please help me.
jeeten29
PL Nut
 
Posts: 23
Joined: 4:28am, Tue 25 Nov, 2014

Re: Blank page on Install

Postby wolfey » 1:31pm, Tue 10 Mar, 2015

Totally blank admin page after minor update to 3.0.12 on SiteGround server running Apache and any flavour of php (as cgi).

Downloaded version again. Unpacked and uploaded again. Always transfer settings to new config file line by line, using 'compare 2 front documents' in BBEdit. First problem updating ever.

Browser shows progress loading page initially, though nothing is rendered and progress bar soon races to finish without error or productive outcome.

Have tried applying 4 different versions of php, from server default to latest offered. No change.

List is very low traffic in every regard. Last entry to log file was 8th March - entirely consistent with the update having broken it.

No idea where to take this next - except backwards, if I can find a previous version.

Solutions? Suggestions? Commiserations?

Thanks
wolfey
phpList newbie
 
Posts: 2
Joined: 1:15pm, Tue 10 Mar, 2015

Re: Blank page on Install

Postby jeeten29 » 4:39pm, Tue 10 Mar, 2015

I was facing same issue and finally I have solved it. Issue was there just because you need to install php-imap package if you have OS
Code: Select all
Fedora/CentOS/Debian/Ubuntu
.
Try it. It will solve your problem for sure.
jeeten29
PL Nut
 
Posts: 23
Joined: 4:28am, Tue 25 Nov, 2014

Re: Blank page on Install

Postby wolfey » 8:07pm, Tue 10 Mar, 2015

Reverted to 3.0.10

Everything back to normal.
wolfey
phpList newbie
 
Posts: 2
Joined: 1:15pm, Tue 10 Mar, 2015

Re: Blank page on Install

Postby Dragonrider » 9:51pm, Tue 10 Mar, 2015

jeeten29 wrote:I was facing same issue and finally I have solved it. Issue was there just because you need to install php-imap package if you have OS
Code: Select all
Fedora/CentOS/Debian/Ubuntu
.
Try it. It will solve your problem for sure.


Glad I was able to help sort this issue. 8)
My sites:- http://wharfedalefestival.co.uk, http://ilkleygardeners.org.uk, http://emergencyaid.net, http://dragonrider.co.uk
Latest phpList version is now 3.0.12 (3 February 2015) and requires a minimum of MySQL 5.0 and PHP 5.3.x
Dragonrider
Moderator
 
Posts: 3460
Joined: 6:58am, Sun 02 Jul, 2006
Location: Ilkley, West Yorkshire, United Kingdom

Re: Blank page on Install

Postby jeeten29 » 3:42am, Wed 11 Mar, 2015

Dragonrider wrote:Glad I was able to help sort this issue. 8)

Yes, sir. I will never forget this issue now. :lol:
jeeten29
PL Nut
 
Posts: 23
Joined: 4:28am, Tue 25 Nov, 2014

Previous

Return to Installing and Upgrading

Who is online

Users browsing this forum: No registered users and 0 guests