Login Problem after Change on Domain Path

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Login Problem after Change on Domain Path

Postby devastor » 4:51pm, Mon 16 Mar, 2015

Hello,

the problem is I can not login anymore in phplist.

The password is correct. The script do not shows me any errors. It simple login and if I click somewhere in the menu I have to login again. This happens with every click, doesn't matter which menu point.

This happens since I redirect mydomain.com to a folder in my httpdocs. This folder called "new", is the folder where is my "list" folder from the script.

Then I tried some things and some other things changed (please take your time to read it if you want to understand what I exactly did):

1. First I was thining: "Of course I have to change the path in the config" and changed this-> $pageroot = '/new/maillist'; ---to-this---> $pageroot = '/maillist'; - because as I wrote I redirect my domain to my new site in the folder "new".

2. Then I was thining: "Maybe the script can not understand, that the domain point to it with mydomain.com/lists, while the folder is in httpdocs/new/lists/ (remember, I only changed the path of my domain to just point that domain to my new site in the folder "new"). Because of that thought I put my whole site inclusiv the "lists" folder directly into the httpdocs folder and changed the path of domain back to normal. No "new" folder anymore and I let the $pageroot = '/maillist' as it was.

3. After changing pointing my domain back to the normal httpdocs folder, I moved the "lists" folder back to the old "new" folder, where it was before - before any changes on my site or the domain. So in reality nothing changed for the script (of course I uploaded the old config with $pageroot ='/new/maillist' where the adminlogin worked perfectly).

4. Because nothing changed I uploaded all files from the clean script again except the config and overwrite my customized phplist files. I changed nothing in the config after the relaunch of my site (redirecting the domain).

5. Last but not least: I reuploaded my customized files, where I have changed some code in the index.php of the "lists" folder for showing a thank you page and so on. After doing that, the script even let me not login one time. If I login now, he try to "initializing the languge" and kicked me straight out of the login after 2-3 secons.

So, I am a little bit dissapointed about that script. The first look was so "wow", you know. Now after my relaunch 2000 people wait for the "Yes, the new site is online and you can use it."

Using the script for the first testmail was a realy good feeling for me. 8)

Sending the first offical email was like "cool, he is not sending all mails but the script can go on with the second click on "resume processing". :?

Second email was like "wow 300 new bounces - why that?" :shock:

Third experiences is "huh, i can not login anymore?" :twisted:

So, I realy hope for help here, otherwise I have a big problem, because I even can not export my customers so easy, because of the descriped login problems and as I wrote it is a realy bad moment for this problem.

I am using phplist-3.0.12 on a apache server with godaddy and centos. I changed nothing on the config between my relaunch and that problem.

Best Regards
Mathias
devastor
PL Nut
 
Posts: 25
Joined: 9:46pm, Thu 05 Feb, 2015

Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 3 guests

cron