Error sending message when processing via commandline

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Error sending message when processing via commandline

Postby ivordurham » 8:16am, Tue 14 Apr, 2015

I have installed phpList 3.0.12 and have successfully sent a test campaign manually via the browser. As the next setup step I changed MANUALLY_PROCESS_QUEUE to zero to process queues via the commandline and created the necessary bash script. When I try to process a campaign via the commandline, I get (recipient e-mail address suppressed):
phpList - Found them: 1 to process [0.0008230000] (120)
phpList - Processing batch of: 1 [0.0005390000] (126)
phpList - Error sending message 3 (1/450) to XXXX@gmail.com (XXXX@gmail.com) [0.0269890000] (150)
phpList - Size of HTML email: 11Kb [0.0002750000] (152)
phpList - Processed 1 out of 1 subscribers [0.0008670000] (160)
phpList - Script stage: 5 [0.0002940000] (162)
phpList - 1 failed (will retry later) [0.0001320000] (163)

Any ideas on why (or how to diagnose why) the failure occurs only when sending the campaign via the commandline but not while sending manually?
ivordurham
phpList newbie
 
Posts: 2
Joined: 7:52am, Tue 14 Apr, 2015

[RESOLVED] Error sending message when processing via command

Postby ivordurham » 4:48pm, Tue 14 Apr, 2015

I discovered that this problem depends on the environment. The failure occurred on a manual installation on a site hosted at HostGator. I replicated the installation on my development system and the queue processed normally. I found a couple of configuration recommendations from HostGator and made the following changes, after which the queue processed normally:

-define("MAILQUEUE_BATCH_SIZE", 450);
+define("MAILQUEUE_BATCH_SIZE", 0);

-define('MAILQUEUE_THROTTLE', 0);
+define('MAILQUEUE_THROTTLE', 8);

-define('MAILQUEUE_AUTOTHROTTLE', 1);
+define('MAILQUEUE_AUTOTHROTTLE', 0);

I cannot explain the actual cause of the original error, but perhaps this discovery may help anyone with a similar mystery.
ivordurham
phpList newbie
 
Posts: 2
Joined: 7:52am, Tue 14 Apr, 2015


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 2 guests

cron