[how to] set default Subject and From line

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

[how to] set default Subject and From line

Postby Lee Pilzer » 2:35pm, Mon 11 Sep, 2006

Nick,

... if there's a way to set ... a default "from line" ...

1. Log-in to the PHPlist "main admin page".
2. Click "configure".

Among the fields on the "configure phplist" page, you'll see the following:

1. From email address for system messages.
2. What name do system messages appear to come from.

When you click "send a message", the "From Line" field is filled-in by default with data from the above two fields on the "configure phplist" page.

-- Lee
Lee Pilzer
PL Master
 
Posts: 205
Joined: 12:26pm, Fri 14 Oct, 2005
Location: New York

Postby kyleknapp » 2:44pm, Thu 19 Oct, 2006

Lee,

Your suggestion seems to only apply to "system messages", not regular messages (newsletters I sent out via the queue).

The settings you refer to are currently set as:

From email address for system messages
noreply@example.com

What name do system messages appear to come from
Webmaster


but when I click "send a message", the "From Line" field is filled-in with

admin kyle@example.com

and the subject line is filled in with

(no subject)

Is there a way to set these defaults?

thanks,
~admin, er, ~kyle
kyleknapp
PL Geek
 
Posts: 67
Joined: 6:39pm, Tue 29 Aug, 2006
Location: Omaha, NE

Postby Lee Pilzer » 7:28pm, Thu 19 Oct, 2006

Kyle,

I don't know why your "From line:" field isn't being filled with the data that you specified.

The information in my reply to Nick (above) does, in fact, apply to what you refer to as "regular messages." The data that one provides for the two fields that I specified will be combined in the "From Line:" field of a message.

For example, if you set the two fields as follows:

1. From email address for system messages: Webmaster@Domain.com
2. What name do system messages appear to come from: Sally Smith

When you click "send a message", the "From Line:" field on the "send a message" page will read as follows:

Sally Smith Webmaster@Domain.com

Check to be sure that you're setting the data for these two fields on the "configure phplist" page.

As for the default data for the "subject" field, I cannot help you. Perhaps someone else will provide an answer for that.

-- Lee
Lee Pilzer
PL Master
 
Posts: 205
Joined: 12:26pm, Fri 14 Oct, 2005
Location: New York

Postby kyleknapp » 8:26pm, Thu 19 Oct, 2006

Okay, I just did what you said, and the result was as I expected, NOT as you predicted. I went to the "configure phplist" page, to:

1. From email address for system messages:
and changed it from "noreply@kyleknapp.com" to "kyle@kyleknapp.com"

and then to:

2. What name do system messages appear to come from:
and changed it from "Webmaster" to "kyle knapp"

Then I created a test message and sent it. While I was creating the new message, the "From:" line showed up as "admin kyle@kyleknapp.com" (no change from before).

The message I sent to myself arrived as from "admin", but the SYSTEM MESSAGE telling me how many messages I had sent and such, was from "kyle knapp", with a source address of "kyle@kyleknapp.com"

"System messages" appear to be automated messages sent by the system (not by me), including user subscription confirmation and Mailing list processing info, etc. Regular "list" messages are unaffected by these parameters.

By the way, the "subject" of various system messages CAN by configured on the same page - but apparently a default subject for list messages (such as "your weekly kyle knapp newsletter") cannot be. Strange, I think.

But it's not a big deal - default "subject" and "from" data can be easily overridden when creating a new message.

It is, however, a bit of a distraction to be given erroneous instructions. (Does this perhaps work differently in different versions? I'm using 2.10.2)

~kyle
kyleknapp
PL Geek
 
Posts: 67
Joined: 6:39pm, Tue 29 Aug, 2006
Location: Omaha, NE

Postby Lee Pilzer » 8:46pm, Thu 19 Oct, 2006

Kyle,

My instructions were not "erroneous." My installation of PHPlist is working exactly as I specified in my last post. Indeed, before making that post I actually changed the settings on my config page and tested them, in order to ensure that I was providing accurate information.

What's even stranger is that I, too, am using version 2.10.2.

Perhaps someone else will have an explanation.

-- Lee
Lee Pilzer
PL Master
 
Posts: 205
Joined: 12:26pm, Fri 14 Oct, 2005
Location: New York

Postby kyleknapp » 9:00pm, Thu 19 Oct, 2006

Lee,

Sorry, I meant no insult.

I notice this question is also addressed at topic #3763, which a much different solution suggested.

~kyle
kyleknapp
PL Geek
 
Posts: 67
Joined: 6:39pm, Tue 29 Aug, 2006
Location: Omaha, NE

Postby kyleknapp » 9:08pm, Thu 19 Oct, 2006

ah-HA!

I just re-read the last post on topic #3763. It explains your instructions will work IF the USE_ADMIN_DETAILS_FOR_MESSAGES parameter in config.php is turned OFF. (It's ON by default)

Okay, problem solved. Still wish I could put define a default 'subject'...

Thanks,
~kyle
kyleknapp
PL Geek
 
Posts: 67
Joined: 6:39pm, Tue 29 Aug, 2006
Location: Omaha, NE

Postby Lee Pilzer » 2:00am, Fri 20 Oct, 2006

Kyle,

According to my notes, the setting for "USE_ADMIN_DETAILS_FOR_MESSAGES" is "0" (i.e., "off", or "not enabled") as of version 2.10.2. This makes sense to me, since I don't recall changing this setting in my current installation. I don't know why this setting was enabled in your setup.

In any event, I, too, am awaiting assistance on setting the default text for the "subject" field.

-- Lee
Lee Pilzer
PL Master
 
Posts: 205
Joined: 12:26pm, Fri 14 Oct, 2005
Location: New York


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 0 guests