[how to] fix problems with displaying special characters öäü

Solutions for other phpList version 2 users
Forum rules
Please do not ask questions here, this is for Solutions you have discovered or come across.

[how to] fix problems with displaying special characters öäü

Postby TomDD » 2:01pm, Sat 24 Feb, 2007

hi,

in textmails the letters öäü would not show correctly.

in the class.phplistmailer.php is the right content:

function add_text($text) {
if (!$this->Body) {
$this->IsHTML(false);
$this->Body = html_entity_decode($text ,ENT_QUOTES, 'UTF-8' ); #$text;
# $this->Body = $text;
} else {
$this->AltBody = html_entity_decode($text ,ENT_QUOTES, 'UTF-8' );#$text;


so, what can be the problem?
TomDD
phpLister
 
Posts: 14
Joined: 12:00am, Fri 16 Feb, 2007

Postby TomDD » 2:12pm, Sat 24 Feb, 2007

ok, i´ve send the messege to another e-mail provider. there i can see the text right. it´s also just text-format.

the other e-mail provider is still not correct.
TomDD
phpLister
 
Posts: 14
Joined: 12:00am, Fri 16 Feb, 2007

Postby H2B2 » 4:20pm, Sat 24 Feb, 2007

Some users have mentioned having problems with special characters and UTF-8.

One fix suggested in the Portuguese forum consists in changing the charset from UTF-8 to iso-8859-1
Admin main page >> configuration >>
- Charset for HTML messages: iso-8859-1
- Charset for Text messages: iso-8859-1
H2B2
Moderator
 
Posts: 7188
Joined: 1:51am, Wed 15 Mar, 2006

Postby TomDD » 8:00pm, Sat 24 Feb, 2007

great job....it works now perfectly :-)

thank you very much...this app is unbeliveable




http://internetmillion.eu
TomDD
phpLister
 
Posts: 14
Joined: 12:00am, Fri 16 Feb, 2007


Return to Answers, Howtos, Tips & Tricks

Who is online

Users browsing this forum: Google [Bot] and 2 guests