Amazon SES works one day, not the next

Once you've installed phpList... ask questions here!
Forum rules
Please help the volunteers to help you by supplying the version of phpList you are using, browser & version and if possible, a link to your phpList installation.

Amazon SES works one day, not the next

Postby lgaetz » 4:21pm, Thu 22 Aug, 2013

I am brand new to phpList, but I know my way around Linux and PHP. I downloaded 3.0.0 for the first time the other day, copied the contents to my web host and generally got everything working fine using gmail as the smtp service. My testing proceeded well, the project is stable and complete and generally exactly what I was looking for. Later that day, I enabled Amazon SES on my AWS account and got the initial 200 msg/day sandbox. In a few minutes I had smtp credentials and a few verified email addresses. I set up phpList with the sandbox SMTP credentials and managed to send email via SES to my verified email addresses. All good, no problems.

Seeing everything work just great, I requested production access to my SES account, which was granted the following day. As soon as my account was approved for production, I have not been able to send another message via SES. Changing smtp credentials back to gmail works fine, so it does not seem to be a phpList issue. I upgraded to phpList 3.0.2, didn't help. I moved the phpList install to another server and sending thru SES still doesn't work. I generated a new set of SES smtp credentials, no help. I can send emails from the SES web form on the dashboard.

config.php details:
Code: Select all
define("PHPMAILERHOST",'email-smtp.us-east-1.amazonaws.com:465');
phpmailer_smtpuser = 'redacted';
$phpmailer_smtppassword = 'redacted';
define('PHPMAILERPORT',465);
define("PHPMAILER_SECURE",'tls');


I really don't know why it stopped working, and I can't figure out how to get at any debug information. Can someone give me a pointer, either how to proceed with configuring SES or how to enable phpmailer debug so I can get a sense of what is happening? Can anyone confirm that phpList 3.x is working fine using SES smtp credentials?
lgaetz
phpLister
 
Posts: 9
Joined: 1:51pm, Thu 22 Aug, 2013

Re: Amazon SES works one day, not the next

Postby duncanc » 10:06pm, Thu 22 Aug, 2013

See http://forums.phplist.com/viewtopic.php?f=24&t=39383#p96603 for how to enable SMTP debug.

There are some errors in the code that you posted. Are they typos or is it really like that?
I don't think that you need to specify the port twice.
duncanc
Moderator
 
Posts: 2440
Joined: 6:34am, Sat 08 May, 2010
Location: London

Re: Amazon SES works one day, not the next

Postby lgaetz » 7:02pm, Fri 23 Aug, 2013

Thanks for the link to enable debug, I will play with that over the weekend.

As for the SMTP port settings, those are the settings that worked initially. I did play around with different port settings, and nothing I did made any difference.
lgaetz
phpLister
 
Posts: 9
Joined: 1:51pm, Thu 22 Aug, 2013

Re: Amazon SES works one day, not the next

Postby lgaetz » 1:10am, Sat 24 Aug, 2013

After reading a note in another thread, I double checked everything and it looks like it was user error. The bounce email address defined in config.php had a typo and was therefore not verifed by SES. I corrected the bounce address typo and cleaned up the SMTP settings as suggested above. Working settings now look like this:

Code: Select all
define("PHPMAILERHOST",'email-smtp.us-east-1.amazonaws.com');
$phpmailer_smtpuser = 'redacted';
$phpmailer_smtppassword = 'redacted';
define('PHPMAILERPORT',25);
define("PHPMAILER_SECURE",'tls');
lgaetz
phpLister
 
Posts: 9
Joined: 1:51pm, Thu 22 Aug, 2013


Return to Questions and Problems after Installing

Who is online

Users browsing this forum: No registered users and 2 guests

cron